lundi 6 mai 2013

Mele V2.0.3 en_US img+sdcard version

This is an update of the v2.0.1 Win8 firmware.

Original thread: The ultimate single-core fun new firmware V2.0.3 released

This is an update from 1.3.1 firmware but I generated a new firmware image (less issues with previous state).

What is fixed:
- avi/mkv/mp4 issues fixed

Here are the modified versions:
Phoenixcard image: v2.0.3_en_US.img
dd-able img: v2.0.3_en_US.ddimg.bz2
sdcard version: v2.0.3_en_US.sdcard.bz2

Edit: fixed the "Unfortunately, the process com.google.process.apps has stopped" issue after having installed gapps.zip, refer to ->this<- post.


Reminder:
PhoenixCard image is flashed using this: PhoenixCardV306
dd-able img is flashed using:
  - under linux: bzip2 -cd Mele_4.0_V1.3BETA_revised_en_us_4.ddimg.bz2|dd of=/dev/sdx bs=4096
  - under Windows: uncompress the archive before, and then use WinImage
The SDCard version is something like a "live-sdcard". You can run it without affecting the flashed image.
sdcard version, under linux only, run: cd sdcard/; make DEV=/dev/sdx (where sdx is the sdcard device number).

This time I chose to not include APEX launcher.
You can download it freely from hereApex Launcher

<not tested>: To get google apps, from the installed Mele firmware, use the Internet navigator and download this:
gapps-ics-20120429-signed.zip
This will put the file in /mnt/sdcard/Download/, where the init script looks at.

Reboot, wait for the device to reboot and you are done.
The details of what is modified in this firmware from the original version:
- boot defaults to en_US
- deactivated /system/lib/hw/sensors.exDroid.so (fixes 100% system_server bug)
- added /etc/init.d capability
- added capability to install gapps if zip present in /mnt/sdcard, by a /etc/init.d script
- removed the Chinese applications (you can still find them in the original update.zip in system/preinstall and system/vendor/app, I kept Flash Player).
- added xpad.ko module (found here: MELE A1000 Hacking - XBOX 360 controller support in 3.0.8 kernel)

48 commentaires:

  1. Thanks!.. I`ve tested today, I dont see any difference between the version 2.0.1, indeed some AVI files dont play well :(... I hope some day will b a firmware which works every file! :D

    RépondreSupprimer
  2. Someone could confirm if netflix is working fine on this version? In the last one there is no video, only audio and subtitle. Thnx
    .

    RépondreSupprimer
  3. Yeah, Netflix is not working on this version. Sound but no image.

    I'm tired of Mele, I can't find a version that works.

    RépondreSupprimer
    Réponses
    1. Indeed, since we don't have access to the firmware source and he Google apps are useless for Chinese people on this device it is hard to get support on this. A better thing would be a Cyanogen build... CM9 is too old, I will try a CM10 version.

      Supprimer
    2. Would be great to have a CM10 version, I will try for sure!
      This version works fine, but the NetFlix issue is important for me, this is the main use of Mele for me.

      Thanks Thierry

      Supprimer
    3. Well, for now, nobody managed to run a CM10 with full hardware acceleration.
      Netflix: Do you know a working firmware? Did you try the "Hide status bar" option in parameters?
      There is a fix for another device/firmware, I doubt that it works, but nobody knows:
      http://www.youtube.com/watch?feature=player_embedded&v=hdCNZrStoYg#!

      Supprimer
    4. mele has not the line that this video says we need to change

      so, that fix cant fix our problem

      Supprimer
  4. Hi thierry,

    some news of your app that change color of led from blue to red during video playing? :)
    Thanks, Gabriele.

    RépondreSupprimer
    Réponses
    1. Well, I did not take time to have something working well but I have an alpha version that goes into red after 30 seconds (if you turn on the switch).
      Here it is:
      http://www.4shared.com/android/aVe5jmRm/LED_Control-01.html
      For now, the only way to revert to normal is to reboot.

      Supprimer
    2. For me doesn't work properly :(

      If there are, i'll wait for a stable version :)
      Thanks;)

      Supprimer
  5. Hi a couple of month ago i buy a mele a3700 from dealextreme and it was installed with your Mele_HTPC_20130116_V1.3.1_en_US_Apex ROM and google apps installed (find out this it toke me a couple of days searching throught all kind of forums related to mele) the thing is that some (not all) videos on youtube make the app force close (no such method : protobuf.codedoutputstream) and couldnt find any info related to this behavior ¿has this happened to anyone else?

    RépondreSupprimer
    Réponses
    1. Do you have a link to a failing video?

      Supprimer
    2. OK, got it just on the first video I took this one:
      https://www.youtube.com/watch?v=URvCgaGYI78
      I will look at this problem...

      Supprimer
    3. I found a workaround, revert to v4.1.23 version of Youtube:
      - uninstall the current Youtube app
      - google find: YouTube v4.1.23 Apk App
      This one works (at least for the mentioned video).

      Supprimer
    4. That version of youtube works perfectly, thanks !!

      Supprimer
    5. Hi Thierry, i install the youtube 4.1.23 butt a stile have the same problem, freezing any time when I try to open the app. Can you help me please? Thanks Alex

      Supprimer
    6. Try to go on youtube via the web browser. For unkown reason it stopped to work for me too...
      This workaround worked for me... I don't know how long it will work :/

      Supprimer
  6. Whoa many thanks thierry :)

    I'll try tonight :)

    RépondreSupprimer
  7. This version does not have Google Play.
    How can I install Google Play to get google apps?

    Thanks.

    RépondreSupprimer
    Réponses
    1. Copy this file http://goo.im/gapps/gapps-ics-20120429-signed.zip on a usb key, plug it on the mele device.
      Using the mele explorer, copy this file from the usb key to /mnt/sdcard/Download/
      Reboot, wait for the device to boot... and reboot by itself

      Supprimer
  8. Hello Thierry!

    I tried this what you said but somehow gapps does not load.

    Thanks for your help.

    RépondreSupprimer
    Réponses
    1. I created a 1-hour application, please install and test:
      http://www.4shared.com/android/W9lAQtLe/GappsInstaller.html

      The file path is preset to get the file from the USB key, plugged at the rear (top connector - usbhost1).
      Put the gapps zip file on a USB key, named "gapps.zip", plug it onto the device,
      From the application, click on "Launch", and wait for reboot.
      If you put the gapps.zip on another path, you can edit the file path before launch (/mnt/extsd/gapps.zip for external SDCard for example)

      Supprimer
  9. Hello Thierry
    I've installed this version successfully and the gapps-ics on mele a2000,
    it was o.k.
    But some apps cannot be installed:
    official xbmc for android ( I get installation failed)
    angry birds.
    Second: have you tried to play HD movies with mele?

    RépondreSupprimer
    Réponses
    1. Strange, angry birds works on my device. I installed it from Google Play and it installed correctly. The only weird thing is that it says "Download complete" while downloading but if you wait, the install succeeds.
      Please install this:
      http://tmerle.blogspot.fr/2013/05/mele-v203-fixing-unfortunately-process.html
      If you want HD movies from Youtube, you must install the 4.1.23 version (not the version of Google Play).
      HD movies play correctly (1080p mkv).

      Supprimer
    2. Thanks Thiery, I've installed the ContactProvider I don't have any problems
      in the Google Play,
      Just one question: which app you use to play HD movies (not from you tube)?

      Supprimer
    3. I use MX Player. It has the option to decode in S/W mode, useful for unsupported avi files by H/W.

      Supprimer
    4. I have installed:

      f03826bf9ac04e18834d855d9e965482 YouTube_4.1.23.apk

      and YT application crashes upon start with:

      /AndroidRuntime( 2006): FATAL EXCEPTION: pool-1-thread-7
      E/AndroidRuntime( 2006): java.lang.NoSuchMethodError: com.google.protobuf.GeneratedMessageLite.
      E/AndroidRuntime( 2006): at com.google.android.youtube.core.model.proto.MobileNusic$MobileGetMusicVideoDataRequest.(SourceFile:4570)
      E/AndroidRuntime( 2006): at com.google.android.youtube.core.model.proto.MobileNusic$MobileGetMusicVideoDataRequest.(SourceFile:4565)
      E/AndroidRuntime( 2006): at com.google.android.youtube.core.model.proto.o.i(SourceFile:4883)

      Supprimer
    5. I experienced that; my workaround was to go through the Internet navigator and search for a Youtube video. All these things are patches and do not fix the Android framework, sadly.

      Supprimer
  10. One question about android settings ¿can you enable them all? what i mean is that in android setting 'account menu' doesnt show but throught other apps that take you diretly there i can add, delete and modify existing accounts (like apps from google that take you there and you can modify sync behavoir)

    Thanks for your great job

    PD: ¿any option to not wipe /data on sd image install? i tried to do this http://rhombus-tech.net/allwinner_a10/hacking_the_mele_a1000/android/ but couldnt mount the hidde npartition.

    RépondreSupprimer
    Réponses
    1. I think it needs some decompilation/recompilation of some apk packages to do that. A better thing would be to have a CM9/CM10 firmware working (this is what I am trying to do), with the sources, that's better.

      To wipe /data on the device, I know there is a special thing to do with /cache/recovery/command and boot in recovery mode.
      Can you test by writing this in /cache/recovery/command:
      --wipe_data
      And use Novo7 tools (see the dropbox link here: http://www.slatedroid.com/topic/33964-novo-7-tools-request/)
      to reboot into recovery mode?
      Be aware that you will loose all your data ;)

      Supprimer
    2. CM10 with hardware support that would be great !!!

      I think you miss understood me i meant NOT wipe data on install but dont worry about that i used Online Nandroid to make a backup just in case i have time to do an upgrade to 2.0.3 version

      Supprimer
  11. Hi,

    one of the biggest problems I have with my mele a2000 is the lack of memory for the processes. I guess the same happens with this new version. I've noticed that the zygote process size is very big (441260 Kb) compared to the size in an Android Virtual Device with 512 Mb where the zygote process is 103408 Kb in size.
    I wonder if this is normal or something to be worried about.
    Any comments about this?

    RépondreSupprimer
  12. hi,
    I wanti install your Mele V2.0.3 en_US img+sdcard version but i dont knows the correct procedure to burno on sd.

    I tried with Phoenixcard but dont'burn
    We have any suggest ?

    RépondreSupprimer
    Réponses
    1. To burn using PhoenixCard, you must take the .img version (http://www.4shared.com/file/oIATNdue/v203_en_US.html)
      Did you use PhoenixCard v3.0.6?
      The SDCard must be at least 2GB.

      Supprimer
    2. I try to use 303, 306 and 309 but I burn only some .img original mele files (eg. 1.3.1 and 2.0.2) but dont your.
      Use 2GB and 8GB sd card
      S.O. Windows 7 pro 64B.
      I tried with Windows 7 start 32B, Vista 32B and Win xp over virtual machine, but nothing

      Supprimer
    3. 309 is OK; 2GB sdcard is OK
      Do you wait the flash process end before removing the sdcard?
      And be careful: you must remove the sdcard after that. Otherwise you will flash again...

      Supprimer
    4. YEs, i'm wait to complete, after exit to 309 and read sd with explore...but nothing, never extract the card.
      I tried more time but nothing.

      I tried also with other card reader or usb SD adaptor in three different pc , but nothing.

      the flash is only worked once with the official release 1.2, but your and MELE and other official versions do not.

      I have now installed, with on-line procedure 2.0.2 (by just copying the file to sd), but I do not like and want to use your own.
      I tried to install your 203 copying directly to SD, it starts the OTA update regularly, but after a reboot I'm still the old version.
      I triend also to install google apps (
      gapps-ics-20120429-signed.zip)
      but at reboot nothing came installed

      I'm really angry, because I can not understand that accident is what prevents me from flash and find improvement by changing the ROM.

      HELP ! HELP !

      Supprimer
    5. Indeed, there are some things weird...
      After PhoenixCard burn procedure, that nominal to see nothing from a PC. The firmware is hidden before the visible FAT partition. Under Windows, I cannot say, but under Linux, if you perform cfdisk /dev/sdb you see that the starting cylinder far greater that 1.
      You will see if it worked by putting the sdcard in the Mele device, and power up. If the blue led starts to blink, that's OK.
      A nominal flash process is like this:
      https://www.youtube.com/watch?v=FzHv5xZCYcU
      A failing flash process is like this:
      https://www.youtube.com/watch?v=36dGI1_ver0

      For google apps, you need my customized firmware since I added a startup script to install it. Otherwise, you can try this application:
      http://www.4shared.com/android/Cnvvopl9/GappsInstaller-11.html
      All in all, theses Mele firmwares (v2.0.x) are not made to run google apps, I added things from the v1.3.1 firmware (that supports google apps) but it runs "by chance".

      Supprimer
  13. Hi Thierry, do you know if there is any new version?
    I want any firmware which can read anything hahah

    RépondreSupprimer
    Réponses
    1. Me too, but sadly no news from Mele...
      I am currently tring to run JB firmwares (Allwinner A10 JB firmwares exist but Mele did not release it yet for their HTPC).
      The main issues are kernel panics, and no USB... hard to find a working setup...

      Supprimer
    2. Ah, new one: v2.0.4
      http://bbs.mele.cn/showtopic-2315.aspx
      Downloading...

      Supprimer
  14. Hi guys,
    This image works fine for me so far. One thing I am annoyed is that the default toolbar at the bottom is not easily available in most screens and applications. How is switching between applications, going to home or forcing stop done in this image?
    10x

    RépondreSupprimer
  15. Wow excellent Job!!!

    I have a question:
    Is there any way to change the boot image????. I hate that picture of Chinese Mele

    RépondreSupprimer
    Réponses
    1. Quite complex, but it is possible.
      You can use the Mele flash kitchen and extract and modify the bootloader image (bootfs.fex). You have to replace files in vendor/system/media/bootanimation.zip (android/*png and part1/*png), and then either rebuild the flasheable .img, or write it in flash directly with dd if=/mnt/extsd/my_bootfs.fex of=/dev/nanda ; sync
      And then reboot.

      Supprimer
  16. thierry,tengo un problema grave con mi mele a2000, al encender no pasa al sitema operativo, esdecir no se ejecuta...queda dando vueltas en el logo de mele...intente hacer un flash con tus archivos de img.peno logro nada..te voy a enviar un video..http://youtu.be/oWXlWa-qz14
    por favor necesito ayuda

    RépondreSupprimer
    Réponses
    1. Seems that your /data gets corrupted.
      I don't know how to tell the device to wipe /data and boot.
      If you are a bit familiar with linux, you can always use the sdcard version, and in this case, the v2.0.4 version:
      http://www.mediafire.com/download/xco43ytnu74nwod/v2.0.4_en_US.sdcard.tgz

      Supprimer