jeudi 17 avril 2014

Mele V2.0.5_2 en_US firmware fixing netflix issue

This firmware is supposed to fix the Netflix issue, thanks to Martinei Gregorio da Silva message, that found that Mele v1.2 version of CedarX libraries were compatible with this firmware.
It is based on Mele V2.0.5 en_US firmware
Same fixes apply, with these additions:
- reverted to Mele_v1.2 CedarX libraries
- added some optimizations in /system/build.prop thanks to
- updated ES File Explorer

Here are the firmware versions:
Customised en_US version: v2.0.5_2_en_US.img
md5sum a9232708517a672e8786cbf2615e5d6d  v2.0.5_2_en_US.img
You need PhoenixCard for this image: PhoenixCardV306

dd-able imgv2.0.5_2_en_US.ddimg.bz2
md5sum 6a23582be63de37b1a4d0ddb06d4e890  v2.0.5_2_en_US.ddimg.bz2
Under linux, to burn it, just perform:
  bzip2 -cd v2.0.5_en_US.ddimg.bz2|dd of=/dev/sdX bs=4096
  sync
Under Windows, use Win32 Disk Imager
sdcard version (sort of live-cd version): v2.0.5_2_en_US.sdcard.tgz
a2b5b32a14c413b859cf229b066a4a6b  v2.0.5_2_en_US.sdcard.tgz
By default, it uses a 4GB sdcard; under linux, uncompress and as root: make DEV=/dev/sdX (X is the device letter of your sdcard)
If you want to change for a 8GB sdcard (you get more space for /sdcard), just change the symbolic link 'partitions.txt' to point to partitions_8GB.txt (rm partitions.txt && ln -s partitions_8GB.txt partitions.txt) before make.

60 commentaires:

  1. I have read that in order to use iconbit launcher and mediacenter you hace to change build.prop like this ro.product.model = iconBIT

    RépondreSupprimer
    Réponses
    1. Indeed, it works! In /system/build.prop I replaced ro.product.model=Mele HTPC by ro.product.model=iconBIT,
      and installed http://files.iconbit.ru/ANDROID_MINI_PC/General_manual_and_software/mediacenter_0.2.7_(04.03.2014).apk
      And got the media applications available.

      Supprimer
  2. Hi,

    I 've recently buyed a mele a2000g, do you think this last firmware you posted will work? which audio patch version should i apply? or does it already includes the audio patch (5.1 downmix to 2ch).

    thank you

    RépondreSupprimer
    Réponses
    1. Hi,
      it should work since this firmware is based on this one:
      http://bbs.mele.cn/showtopic-2538.aspx
      said to be compatible with A100,A1000,A1000G,A2000,A2000G,A3600,A3700

      Supprimer
    2. I tried to make a bootable SD-card version and boot it in my A2000G, just now. This resulted in a black screen...

      What is the general method for creating this bootable ROM? Also, where can I find ROMs for the A2000G to download?

      There doesn't seem to be any central repository for firmware for this device, unfortunately. Also, I keep coming up on dead links on the MELE forum...

      I'd like to have some Android 4.x variety and Arch Linux or something like that to switch in and out at will...

      Thanks for any help :)

      Supprimer
    3. Ce commentaire a été supprimé par l'auteur.

      Supprimer
    4. (re-posting, I made a typo I fear)
      This rom is intented to work for A2000G, I don't think Mele released any other firmware specific to A2000G....
      The sdcard version must be uncompressed under linux and you must perform the "make DEV=/dev/sdX" command.
      Should work...
      Archlinux works well on sdcard.

      Supprimer
  3. I didnt know, but if you get pressed the apllicatoin icon it appears in iconbit menu, its a very good, simple and configurable launcher

    RépondreSupprimer
  4. Tell me please how a layman has to modify:
    In / system / build.prop and replaced ro.product.model = Mele HTPC to ro.product.model = IconBit,
    and install http://files.iconbit.ru/ANDROID_MINI_PC/General_manual_and_software/mediacenter_0.2.7_(04.03.2014).apk

    I managed to upload Mele V2.0.5_2 en_US but I would get rid of the Chinese
    stamps and have google play. Is this possible using the software? if you have to have some hardware?

    sorry for my English I'm still learning :)

    Regards
    trend

    RépondreSupprimer
    Réponses
    1. Please try this tutorial:
      http://forum.xda-developers.com/showthread.php?t=1193245
      But change ro.product.model instead of ro.sf.lcd_density

      Supprimer
  5. I have a dream V2.0.5_2 en_US plus build.prop = IconBit plus google play
    is this possible?
    the root mele a2000g joined with some underdone screen.
    I guess I'm too much of a layman to realize my dream.

    RépondreSupprimer
    Réponses
    1. Nothing prevents that... should work

      Supprimer
  6. Hello,
    Just installed that version and I can't install gapps.
    I checked data folder (empty).
    And when i launch the gapps installer it reboots (fine) but no gapps there.
    Is there a procedure through adb which you could detail please ?

    Regards
    Pierre

    RépondreSupprimer
    Réponses
    1. Did you try the gappinstaller?
      Otherwise, via adb you can push the gapps.zip file in /mnt/sdcard:
      adb push gapps-ics-20120317-signed.zip /mnt/sdcard
      and then launch manually the installer script
      adb shell /system/etc/init.d/10update_gapps
      the device should reboot at the end.

      Supprimer
  7. Thank you! I worked perfect for Melee M10, Netflix also fix, I need to see Google play, but for now it is not urgent

    RépondreSupprimer
  8. aa my bad , MELE a1000 Allwinner A10 , but , its posible to install Google Play ? ... thanks again !!

    RépondreSupprimer
    Réponses
    1. Yes, possible. Please see above the answer to 'pierre' for the ways to install it.

      Supprimer
  9. Hi im spanish guy sorry for my english... First i have woxter 500 tv.. I can use this firmware , no ? Is a clone of mele a2000.


    -Can you explain that it serves v2.0.5_2_en_US.sdcard.tgz ?
    I do not understand it takes.

    -How do I update the firmware? I'm on windows.

    -From what has to be the SD card?

    thx a lot !

    RépondreSupprimer
  10. Hi again i upgrade my firmware but.. i cant use without a real keyboard? cant i use with a qwerty ?

    RépondreSupprimer
  11. im here again :P i found the virtual keyboard. All is working !!! thx for all man !!! continu

    RépondreSupprimer
    Réponses
    1. HI!
      I have a problem my mele a2000g.
      I installed 2.0.5 US firmware few month ago, and it worked.
      But now I always receive "Mele launcher stopped" error message, and my player totally usefulness.
      I tried to install, the firmware again, but did not help.
      I tried install 2.0.5.2 , but I receive same error.
      I must install official 1.2.3 firmware. It is works. But If upgrade 2.0.5, I receive error again.
      Any idea?

      Supprimer
    2. Hi,
      don't know ; perhaps the firmware file you are flashing is corrupted...
      You can try to re-download the firmware.

      Hope this helps...

      Supprimer
  12. Here you can download a non corrupt version of the zip file to instaló gapps (Google Play, Hangout, etc .. ) with the gapps installer.

    https://code.google.com/p/android-google-apps/downloads/list

    RépondreSupprimer
  13. PS4 Modded Controllers is perfect for those who love their old 360 controllers, or had a real expensive modded 360 controller and now don't have to worry about buying another, or want to use a PS4 Dual shock 4 controller or want that extra edge by playing with a keyboard and mouse. Naturally you have full access to all of the mod packs too so you can now play with a fully modded controller on your Xbox One Modded Controllers - including our latest addition to the mudpack range, CALL OF DUTY GHOSTS V1.0 - again supplied free of charge and will be out very soon (Until it is released you can use the Call of Duty Series v1.7 Game Pack to work with COD Ghosts on the Xbox One)

    RépondreSupprimer
  14. Hi.. do you know if there is a a new faster firmware? or something..??
    The win 8 interface is really slow :(
    thanks

    RépondreSupprimer
  15. Hello,
    I buy a chinese Version from mele A1000G!

    I search now 2 days for change the Firmware :)

    So my question is now, after I find this blog, can I change the Firmware to this one what is here avalibale or give it now a higer version!?

    On the Chinese the Version is 3.x.x

    Hope I get a answere on my question and someone can help me.

    thanks
    Joerg

    RépondreSupprimer
    Réponses
    1. Hi,
      it should work since this firmware is based on this one:
      http://bbs.mele.cn/showtopic-2538.aspx
      said to be compatible with A100,A1000,A1000G,A2000,A2000G,A3600,A3700

      Supprimer
  16. Hello...
    I've been using Netflix, I installed the lastest apk, the problem is, the resolution is really bad... so, the film doesn't show well... any help, please?

    RépondreSupprimer
  17. Having trouble downloading the IMG file from 4Shared. Any other link available?

    RépondreSupprimer
    Réponses
    1. I uploaded the .img file on mediafire:
      http://www.mediafire.com/?0ntx4o6u77wz1

      Supprimer
    2. Hmm... correct link is: http://www.mediafire.com/download/vcnkhejsaboi7s4/v2.0.5_2_en_US.img

      Supprimer
  18. Installed on a mk802ii, works perfectly, after installing gapps-ics-20120429-signed.zip, errors came. I will reinstall without it and try other .apk of google play store.

    RépondreSupprimer
    Réponses
    1. Some of the Date and Weather letters are still in chinese and is there any ways of removing the Mele logo and change the overall display ? (Colors, background image etc.)

      Supprimer
    2. For the google apps, I decided to give up and use the without-google play method here: http://tmerle.blogspot.fr/2014/01/how-to-install-applications-without.html

      Supprimer
    3. For the Mele logo & display, you mean the launcher? You can install an alternate launcher. I like the Xperia one: http://forum.xda-developers.com/showthread.php?t=2368506 (take the ICS version).

      Supprimer
  19. Just in case anyone still cares about the mele, the next command line (root required) will increase the performance a bit, overclocking the default 360Mhz ram clock to 408Mhz.

    /system/bin/busybox devmem 0x01c20020 32 0xb1059191

    I have been using it in an init script for almost a year without any issues at all. Previously I tried to overclock modifying the script.bin without any sucess.

    You can check your current dram clock with this tool:

    https://github.com/maxnet/a10-meminfo

    RépondreSupprimer
  20. Hi !
    my board have 1GB RAM, but v2.0.5_sdlive view only 307MB RAM
    how to make visible all 1GB RAM ?

    Best regards,
    Ivan

    RépondreSupprimer
    Réponses
    1. Hi
      Well, it took time since I run this device on linux now...
      Indeed that's not the expected 1GB, and that's why you get 307MB RAM under Android...
      You should be able to play with the boot arguments (on first partition, file uEnv.txt, add mem=1024M at the end of extraargs= but this doesn't work.
      Hmmm... I realized it cannot work for me, I have a A2000 limited to 512MB (http://linux-sunxi.org/Mele_A2000).
      You can try on your board...

      Supprimer
  21. Hi
    It was possible to solve the problem !
    Writing new u-boot-sunxi-with-spl.bin from mele a3700
    Download from here http://dl.linux-sunxi.org/nightly/u-boot-sunxi/u-boot-sunxi/u-boot-sunxi-latest/u-boot-sunxi-mele_a3700.tar.xz
    Now seen 814mb RAM

    RépondreSupprimer
  22. Hi , ¿anyone still has sdcrad version v2.0.5_2_en_US.sdcard.tgz file? trying to revive an almost dead mele a2000 but the version sdcard live i have has problem with netflix (only audio is played for movies , video goes black)

    RépondreSupprimer
    Réponses
    1. I changed the 4shared links to mediafire links. I don't use 4shared anymore since I have some issues with this service.
      The sdcard version is here: https://www.mediafire.com/?csp6ynus6ov5p3g

      For the netflix issue, I don't have it so I can't help sorry. Perhaps an older version of the netflix app could work?

      Supprimer
    2. Thanks a lot , i got working yesterday (found the sdcard version on an old harddisk on an old machine jajaja) , it seems that the problem is with the flash app or youtube app . the last time i dindnt update flash nor install youtube and its working fine .

      Thanks anyway for your great work.

      Supprimer
    3. One last question ¿how can i manage google account on the device? i used my email for first setup of google play but i want to change it because im not the one that's using it .

      Try looking every were but couldnt find a way to delete my account and use another

      Supprimer
    4. I don't know... perhaps you can access to accounts & sync settings like in this video: https://www.youtube.com/watch?v=YuSiCog4Zv0

      Supprimer
  23. Hi Thierry,

    My Mele A200 started showing Internal Storage 0.0B, so I wanted to test boot your v2.0.5 FW mod from SD Card without writing the new image to NAND. However, there seems to be a problem with mkA10card.sh script (http://pastebin.com/wD4SscMK). Gparted also can't recognize the created partition types (http://oi65.tinypic.com/fnbfra.jpg). I originally formatted the SD Card by SDFormatter in Windows, and it works OK in Windows and Linux, when formatted manually in Gparted.

    Can you fix the script pls? You mentioned here (https://tmerle.blogspot.ca/2013/08/mele-v205-enus-firmware.html), it was already fixed, but may be you uploaded to Mediafire the old version, when 4shared expired?

    RépondreSupprimer
    Réponses
    1. Well, it worked for me... with a 8GB sdcard:
      http://pastebin.com/Z1eGc6Wx
      I changed my harddisk and removed the old versions of the mele firmwares and scripts (I did a stupid thing that day). But I think this script is the latest.
      You can try to change the partitions.txt symbolic link to point to the 8GB version (rm partitions.txt && ln -s partitions_8GB.txt partitions.txt).
      There is a partition alignment issue on you sdcard; you can fix this by manually setup the partitions in gparted, then perform sfdisk -d /dev/sde ; this will generate a partitions.txt file that fits your sdcard.

      Supprimer
    2. After a few SDCard reformats, the script worked. However, there were no signs of any boot activity, when I inserted this card into A200 slot and powered the device. What files do I need to replace to make A200 boot this build? Its outrageous, Mele deleted all firmware for this device from Baidu storage.

      Supprimer
    3. Strange... the script is supposed to re-create the sdcard from 0.
      The boot partition contains script.bin which is the description of the hardware. You can replace it by your device's script.bin to test. To debug the startup you will need to wire the serial interface.
      To find the old firmwares, you could ask on the blog http://touchscreen-apps.blogspot.fr/2013/01/mk802ii-firmwares-gathered-on-one-place.html if he kept the versions of firmwares.

      Supprimer
  24. If I write FW from a different device to NAND, and it can't boot, the device will become brick - correct? Because I don't have factory FW to restore it, and can't install recovery tools like CWD (and there's no ROM for A200 anyway). Even recovery via hardware button won't work, since the Recovery partition will be erased - correct? So do I have any other options apart from trying to boot some FW directly from SD Card?

    RépondreSupprimer
    Réponses
    1. If you don't have a A200 firmware you are sure you can flash to recover from, you are right, you should'nt do any modification on your current flashed firmware.
      Something you can test with the sdcard version: retrieve the script.bin from your device (it is in the bootloader partition, nanda).
      You can try to boot your device with archlinux:
      https://archlinuxarm.org/platforms/armv7/allwinner/cubieboard to retrieve information like I explained on http://tmerle.blogspot.fr/2012/11/handling-nand-flash-to-saverecover-data.html
      If everything goes well, you will connect to your device via ssh (login root password root), mount bootloader partition (mount /dev/nanda -o ro /mnt, and copy files (scp root@ip:/mnt/script.bin .)

      Supprimer
    2. From this discussion thread:
      https://groups.google.com/forum/#!topic/linux-sunxi/-HfHG-yyCVs[1-25]
      The A10s (CPU of Mele A200) is based on Allwinner A13 and not Allwinner A10.
      So my firmwares won't work, you should try a A13 firmware, and try it with the sdcard version.

      Supprimer
    3. Hi Thierry Merle, I have a Melle A2000G with the following problem: Do not exit the bootloader step to open the normal operating program. What can I do to fix this and reuse the videoplayer? thank you

      Supprimer
    4. Hi,
      you need to re-flash the firmware, but you will loose your data...
      From the discussion thread in this post, I see that several users had success with this firmware on a A2000G.

      Supprimer
    5. Thierry, I tried the introduction of the new firmware with sd card (img), but not loading continues showing the logo mele the led does not blink, it stays on static, what else can I do?

      Supprimer
    6. My problem it is exactly like this: https://www.youtube.com/watch?v=oWXlWa-qz14

      Supprimer
    7. So you tried v2.0.5_2_en_US.img?
      This bootloop is due to failure to run the system partition (not found or corrupt).
      Strange since this image wipes partitions and resets the device.
      Otherwise you can try the 'sdcard version', that boots without the need of the internal flash.

      Supprimer
    8. I'll try this. thank you !

      Supprimer
    9. Negative. Would there be some sort of recovery through Rs232 for this device?

      Supprimer
    10. Yes, wiring the RS232 will give information.
      The board should look similar to the A2000.
      http://linux-sunxi.org/Mele_A1000#Locating_the_UART

      Supprimer